Ignation Problem E-350

30

Asked by dyessri Feb 07, 2013 at 12:33 PM

Question type: Maintenance & Repair

Was Driving home and all dash power went off no gauges and no warning lights engine died. head lights radio and fans stayed on. had van towed home. Now when the ignition switch is in the run position no gauges and no warning lights. all other electrical works. when you turn towards start the gauges come on and warning lights come on just before the starter engages release to run and all gauges and lights go out and engine will not run. any Ideas?? Possible relay somewhere?

2 Answers

take a look at your harnesses at the firewall. one or more of them could have jotled loose. You may have had a hitchhiker with big boots and long legs and punchity punched the firewall a couple of times as he tucked his ass in- perhaps you were on a rugged road that jostled things loose...a bit in an intermittent fashion. pull and replug this connection to the dashboard to see if it all comes to life once more please-

2 people found this helpful.
30

Found the problem It was a relay inside a cole-hersee power switch that connects the batteries to the electrical system.

3 people found this helpful.

Your Answer:

Shortcuts

Ford Experts

  • #1
    OJ
    Reputation
    59,120
  • #2
    G A Arne
    Reputation
    57,780
  • #3
    F_O_R
    Reputation
    54,540
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.