E150 4.6l van stalls at stops after 15 seconds

Asked by Blairville4 Jun 05, 2019 at 04:29 PM

Question type: Maintenance & Repair

I have I have a 1999 E1 50 Ford 4.2v I have a 1999
E1 50 Ford 4.2l  Engine. It is stalling after 15
seconds at a stop light. Idles perfectly. Just
suddenly loses its smooth idle and then stalls
unless we keep foot on the gas. Cleaned the idle
control valve replaced the purge valve, checked
and change gas caps,  cleaned MAF sensor. Ran
three Cans of seafoam in it. Tried both new maf
sensor and IAC but made no difference. Changed
spark plugs and wires. Throttle body looks good.
OBD sensor says fuel trim is lean.  It runs very
good. Smooth idle. Not burning gas. Any ideas?

3 Answers

355,315

Cleaning the idle control valve may not have been enough.

I replaced it with a new one and it made no difference. Same with the MAF sensor.

So I took them back after cleaning them. MAF sensor readings were good on the app I used for OBDII

Your Answer:

Ford

Looking for a Used Ford in your area?

CarGurus has 28,001 nationwide Ford listings starting at $1,490.

Postal Code:

Shortcuts

Ford Experts

  • #1
    OJ
    Reputation
    58,840
  • #2
    G A Arne
    Reputation
    57,320
  • #3
    F_O_R
    Reputation
    54,330
View All

Find great deals from top-rated dealers

Search

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.