Speedometer not working and transaxle hold light flashing

Asked by Tmersh Mar 06, 2019 at 12:14 AM about the 1992 Mazda Protege

Question type: Maintenance & Repair

While at a stop after driving for a bit, speedometer
didn't read anymore and the hold light for the
transaxle started flashing. The car shakes some at
any long red lights. But I can't figure out if maybe a
wire to trans broke or came loose. And yes I swear
it happened at the same time. The car shifts 1st
2nd and 3rd gear. I don't drive far or fast enough to
check for possibly 4th gear (inside the city). How
can I check to see if the hold wire came undone?
No I haven't checked for the speed cable just yet
on 92 protege.

1 Answer

I did just drive the car and it did feel like it shifted into 4th. Could if been only 3rd but it felt like 3 shift from being stopped to when I left off the gas.

Your Answer:

Mazda Protege Experts

  • #1
    James Kithuka
    Reputation
    420
  • #2
    dandyoun
    Reputation
    260
  • #3
    Craig Barton
    Reputation
    240
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Mazda MX-5 Miata
26 listings starting at $19,990
Used Honda Civic
146 Great Deals out of 7,773 listings starting at $490
Used Honda Accord
53 Great Deals out of 1,602 listings starting at $100

Used Cars for Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.