My blazer

Asked by Eric Feb 12, 2019 at 10:16 PM about the 1986 Chevrolet S-10 Blazer

Question type: Maintenance & Repair

So my 86 s10 blazer was running after i replaced the coil
pack spark plug and wires started no problem had it
running and the coil pack fryed ive replaced the coil pack
again and same thing idk what my issue is?

1 Answer

7,060

Are you using OE coils? It's hard to fry a coil they do that all by themselves if they're not insulated correctly, Chinese stuff does that often.

Your Answer:

Chevrolet S-10 Blazer Experts

  • #1
    Cody Doud
    Reputation
    1,070
  • #2
    emtfirefighter77
    Reputation
    790
  • #3
    Markfisler
    Reputation
    580
View All

Find great deals from top-rated dealers

Search

Related Models For Sale

Used Chevrolet S-10
8 listings
Used Chevrolet Blazer
599 listings starting at $4,900
Used Chevrolet Camaro
16 Great Deals out of 460 listings starting at $10,998
Used Ford Mustang
35 Great Deals out of 1,176 listings starting at $4,450
Used Ford F-150
117 Great Deals out of 8,437 listings starting at $3,490
Used Ford Ranger
5 Great Deals out of 1,050 listings starting at $3,900
Used GMC Jimmy
5 listings
Used Chevrolet Impala
19 Great Deals out of 499 listings starting at $2,200

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.